I lost my ability to use Lingvist yesterday and it is not working for me again today. I am able to log on. I am presented with a card. My first answer is accepted normally and a second card presented. On the second card I type the answer and press return and the field clears, but no voice is activated and the card remains displayed. I can no longer access or type in the text field. I cannot advance the card by clicking the arrow at the right of the card. I can reveal and hide the translation, but the card itself remains frozen in place with an empty text field.

I use a Mac computer and the Safari browser, but I have not made any changes or updates to my system which has been working perfectly from the beginning of my account several weeks ago. I have looked around the Lingvist web site for any news or announcement of any changes that might have caused this, but I don't see any. So I don't have any idea why this might be happening. Also, since there are no other posts about this, I assume it is only happening to me.

I would appreciate any suggestions about how I might troubleshoot this problem. I would hate to have to leave Lingvist, as it is the best free learning option I have seen anywhere on the web!

Hi @Jamie, it works for me, so it's indeed likely that the problem is on your end. There are a couple of things you could try out, ranging from less to more intrusive:

  • have you tried reloading the page bypassing the cache with OPTION + CMD + R (Safari 11.1)?
  • have you tried to log in from the private mode?
  • is there any other browser installed that you can test with?
  • have you tried clearing cache and cookies for lingvist.com and lingvist.io and then log in again?

Thank you very much for the help. I tried all your suggestions (and a few other things, like restarting Safari and rebooting my Mac) but was not able to get Safari to work again with Lingvist. But Firefox is working fine, so I'll just use it instead. I would like to know why Safari stopped working and fix it, but honestly, I don't have the time or patience to try to figure it out as long as Firefox is working. You're a life saver, getting me up and running again. Thanks so much!

Hi @Jamie

is there something like a web console to see JS errors available on Safari, like it is with Firefox (you can press F12 on Firefox).

When Memrise screens stop working, then this is because of that the web applications usually throw a red error and they can not recover from this.

Sorry, I have no experience with Mac and Safari browsers...

If the problem persists even in a private mode there is a high chance that lingvist devs have broken Safari compatibility. I've left my Mac at work, so I can't verify it myself at the moment. As you now have a temporary workaround, we would probably sit and wait for lingvist people to take a look at it sometimes this century.

  • 5
    Posts
  • 69
    Views