Can't access the Lingvist forum on Firefox

  • Hello Lingvist-team and @dev_temp since he might know a solution.

    For about a month now I am unable to access the Lingvist forum. I thought it was just an issue with the forum or a Firefox update but even with Firefox 54 and all addons deactivated I still can't use the forum. It just says:" Looks like your connection to insert topic was lost, please wait while we try to reconnect.". It works on Chrome.

    I'm not very familiar with webdev but the console outputs:

    GET XHR [HTTP/1.1 400 Bad Request 36ms]

    Access-Control-Allow-Origin *
    Connection keep-alive
    Content-Type application/json
    Date Fri, 23 Jun 2017 22:52:19 GMT
    Server nginx/1.4.6 (Ubuntu)
    Transfer-Encoding chunked

    Does anyone else have a problem like this?
    I really don't want to do a reinstall...

  • @ThePikmania said in Can't access the Lingvist forum on Firefox:

    "Also, there is one field missing in your cookies"- Did you mean "Set-Cookie"? Because it's there now.

    No, it's "io", actually.

    @ThePikmania said in Can't access the Lingvist forum on Firefox:

    Thanks for your time. 🙂

    Gern geschehen!

  • @dev_temp It's impressive that you noticed this! Yes "Network.http.sendRefererHeader" was set to 0 for me and I noticed that some other variables were "set by the user" aswell. I must have had some extension/addon that changed these installed. But disabling or deinstalling addons didn't change them back.

    "Also, there is one field missing in your cookies"- Did you mean "Set-Cookie"? Because it's there now.

    Thanks for your time. 🙂

  • Hi @ThePikmania I guess I've found a probable reason and was able to reproduce the symptoms on my side. There are no "Referer" field in your requests. When I disable this field, I also get 400. Check that option, it set to 2 by default and it works fine with that. Have you played around with some privacy tools that might have disabled it? Also, there is one field missing in your cookies, though I'm not sure where it might have gone, I just hope it'll be set along with the proper response.

  • I really appreciate your help.
    I am not one to easily give up on problems especially when they are programming related, but I feel like I spent too much time on this problem whose topic I know little about.

    ...anyways here are the pictures:

    The log:


    My Chrome log for comparison:

    I deleted every cookie regarding Lingvist and temporarily disabled Avast but it still wont work. 😞
    And every discussion I found about it was from the servers side of view.

  • I would rather try to solve the problem than just abandon it as it doesn't supposed to work that way. Did a superficial digging about, looks like it sends more detailed error info inside response body. If you would be so kind to take a look at dev tools->network and expand a failing response like this:
    It may shed some light. Though it still strange to me that practically clear (no plugins, no cookies, no cache) FF behaves that way. Any chance your antivirus is trying to temper your connection?

  • Thanks @dev_temp for your suggestions.

    I tried them but it still doesn't work for me. So I'll just use Lingvist on Chrome for the time being.

    A few years ago I had some trouble with certain Twitter functions so I just used Chrome instead and when I tried it again on Firefox a few months later, it worked again.

  • @ThePikmania said in Can't access the Lingvist forum on Firefox:

    Hello Lingvist-team and @dev_temp since he might know a solution.

    Hello @ThePikmania, I feel like a local celebrity right now 😄
    Firefox is my browser of choice and I had no issues accessing the forum with any of the updates, so it's probably not the root case for you either. From the top of my head, I can think about two ways that things could go wrong:

    • messed up cache or cookies. I would start with refreshing the cache (that should eliminate cache from the equation) and if it doesn't help I would just try my luck with private browsing mode (if you can login in private mode, you should probably clear your cookies);

    • another probable cause is some nasty plugin playing tricks on you. You should try lunching FF in a safe mode that would disable all plugins. If it helps, you would have to disable all plugins in a normal mode and then enable them one by one, until you find which one is to blame.

    I hope it helps.

Log in to reply

Recent topics: