Speech not working

Hi community & lingvist team,

I have a problem regarding speech on android. Whenever I press the microphone button, a Listening loading dialog appears and then, nothing happens and I can't do anything before I shut down the app.

Another problem regarding speech...It seems that nothing happens when I press the microphone button in the challenges. I don't even know whether I have to press all the time during my speech or I have to press once and the system tries to detect my voice..in any case, it has not recognized my voice once.

In the settings, speech is turned on.

Thanks for raising this topic.

We have got few reports about this issue, but we have not figured it yet out what is causing the trouble.

We have tested the feature to work well on Samsung and Google phones, plus on emulators.

We tend to think that the issue is probably device or device software specific.

Have you tried to speak when the dialogue appears?

Did you grant us the speaking permission on your phone when you first time interacted with microphone?

What phone do you have?

last edited by Raul Liive

Yes, I have tried that. Nothing happens.
I don't think there was any permission that I needed to give. I reinstalled the app but that didn't help neither.

last edited by Benjamin Bergner

Hello,
My microphone is not vorking also. My phone is Sony Xperia.

Can you please both give to me your phone's exact model number?

Also please state if you have altered the phone firmware in any way.

I have had few other complaints on this issue, but for them we have managed to detect that the other affected people used phones which did not had from factory Google Play and Google API's installed.

This can happen mostly on two occasions

  • Person buys a phone meant for Chinese local market
  • Phone has third party firmware installed.

Would like to figure out if it's the same trouble your affected with or something else.

I cannot seem to input speech on any device. I have tried on my Android Moto X, my PC, and my windows 10 tablet. Everytime I tap the mic icon it just beeps and says"we didn't get that". On my windows devices it does nothing at all. I even tried the beta app and same thing.

Sure, model number: X5pro as in the settings

Even though this is an asian phone, other apps get speech to work, too :-)

Looks like your connection to Home was lost, please wait while we try to reconnect.